逆引きマニュアル: Gradle Wrapperの更新

投稿日: Gradle

やりたいこと

Gradle Wrapperを更新する。

前提条件

概要

手順(Gradle Wrapperが起動しない状態)

例えばJava 9にしたときに、古いGradleが起動しない場合。

  1. gradle/wrapper/gradle-wrapper.properties を開き、distributionUrlを更新
    • 最新バージョンはInstall参照。
  2. ./gradlew wrapper
    • gradle/wrapper/gradle-wrapper.jar が更新される。

参考: Java 9でGradleのエラー「Could not determine java version from '9.0.1'.」が出るときの対処方法 - Qiita

手順(それ以外)

以下の通りにする。

Gradle wrapper のバージョン更新についてのメモ - Qiita

制限事項

マニュアル



ページトップへ戻る